Email delivery - Degraded Performance in receiving e-mails
Incident Report for Radancy's Employee Referrals
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 08:54 CET
Monitoring
A fix has been implemented by our email delivery service provider. We are continuing to monitor email delivery.
Posted Dec 11, 2023 - 21:05 CET
Investigating
We are currently having an issue with our Email Delivery Service. We are already loooking into this issue.
Posted Dec 11, 2023 - 17:20 CET
This incident affected: Notifications (Email) and Transactional Emails.