Email delivery - Degraded Performance in receiving e-mails
Incident Report for Radancy's Employee Referrals
Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 08:08 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2023 - 08:23 CEST
Investigating
We are currently having an issue with our Email Delivery Service. We are already loooking into this issue.
Posted Mar 31, 2023 - 16:56 CEST
This incident affected: Transactional Emails.